• Hi All

    Please note that at the Chandoo.org Forums there is Zero Tolerance to Spam

    Post Spam and you Will Be Deleted as a User

    Hui...

  • When starting a new post, to receive a quicker and more targeted answer, Please include a sample file in the initial post.

Setting cell.Value acting differently in Win 10

For a few years now I've been running my time sheet in Excel 2010 under Win 7, but I recently switched to a new PC with Win 10 and Excel 2019 and its behavior has changed in a minor but annoying way. I'm hoping someone can tell me how to fix it.

When I begin or end work on a project, I double-click on a cell; the BeforeDoubleClick code for that worksheet puts into that cell either the current time or an Excel formula, depending on the circumstances. Under Win 7 and Excel 2010 that worked as you might expect: I'd double-click on a cell and the value 16:38 (for example) would appear in the cell.

Under Win 10 and Excel 2019, however, what appears is "16:38:00" and the cell is left in data-entry mode (as though I'd hit <F2>); the value is displayed, but I have to hit <Enter> manually to continue. It's a small thing to hit <Enter>, but I do it many time per day and I didn't use to have to do that. Does anyone know what's changed, and what I need to do to get back to normal?

(The actual value being plugged in is 0.693055555555556, if that matters. I suppose it doesn't.)
 
Jolivanes, there's already a format on the cell ("hh:mm;-General;"). But changing the Selection to another cell afterward didn't occur to me. I'll try that; thanks.

(I did think of simulating hitting <Enter> in the macro, but I was trying to avoid that if possible. I'll probably try that, too, just to see which works better.)

Fluff13, I can try that too. What I'm wondering, though, is why it's in Edit mode in the first place?
 

Fluff13

Active Member
Double clicking a cell puts you into edit mode & is the default behaviour.
You can change that by going to options > advanced > uncheck the box "Allow editing directly in cells"
 
Ah, that's it! I had that turned off in the old copy of Excel but not in the new. Thanks, Fluff, that did the trick.
 
Top