• Hi All

    Please note that at the Chandoo.org Forums there is Zero Tolerance to Spam

    Post Spam and you Will Be Deleted as a User

    Hui...

  • When starting a new post, to receive a quicker and more targeted answer, Please include a sample file in the initial post.

Filter not including last row

TarunVerma

New Member
I Know this condition if first column has some data but not till last row then filter applies till First Column Data.
but in attached sample Column A is blank and while applying filter last row of data is not coming into filter.
Any comments why not including last row? any help from you side will solve my problems.
Thanks in advance.
 

Attachments

GraH - Guido

Well-Known Member
Hi,

I've experienced the same behavior before.
Strangely in your file, adding a new record solves the problem. Delete that new row and the problem reappears.

I recommend using tables, since they resize when adding new columns/rows (if the feature is not turned off in the settings).
 

pecoflyer

Active Member
Having taken a minute to search the Net I have found that this behavior is due to the use of the SUBTOTAL function in col C
Change this formula to =SUBTOTAL(your parameters)*1 and everything is OK now
(I'll leave it up to you to find the explanation) :)
 
Last edited:

GraH - Guido

Well-Known Member
I checked that, and it does not solve the problem
It did on my end though...
75245

As a side note. The use of subtotal was certainly not the cause in my workbook. I suspected it was the way new data was added in the file. With or without filters being set. (auto filter was always on, but filters used or not used). But this was not the cause in this file. Never would have thought a function would be to blame. But it clearly is. Using =AGGREGATE(2;4;$B$3:$B3) also solves the problem.
 

pecoflyer

Active Member
Strange, I tried it both ways on XL2010 and the last row was still missing ( before changing the SUBTOTAL function)
 
Top