• Hi All

    Please note that at the Chandoo.org Forums there is Zero Tolerance to Spam

    Post Spam and you Will Be Deleted as a User

    Hui...

  • When starting a new post, to receive a quicker and more targeted answer, Please include a sample file in the initial post.

New Pivottable does not show in slicer connection window

Wilco()

Member
I created a dashboard using 1 pivot table and slicers.

I needed a new pivot table and wanted to connect the existing slicers to the new pivot table. However, the slicer connection is only showing 1 pivot table. The new pivottable does not show up.

How can I solve this?
 

Wilco()

Member
I must add, that when I create a new slicer with the new pivottable this works. Now I tried to connect this with the first pivottable and now only the new pivottable shows up in the connection window.

The pivottables both use the same data set. Only the old one, filters a couple of records out. Which I need to show up on my dashboard. That's why I created a new pivottable.

It might be my lack of understanding how this connection/pivot tables work. As I do not have a clue, why it is not showing up in the connection screens.
 

ashish mehra

Active Member
Hi Wilco,

Right click on Slicer & click Pivot Table Connections & select the Pivot Table number.

Try consider sample file.

This will be resolved.

Regards,
AM:)
 
I must add, that when I create a new slicer with the new pivottable this works. Now I tried to connect this with the first pivottable and now only the new pivottable shows up in the connection window.

The pivottables both use the same data set. Only the old one, filters a couple of records out. Which I need to show up on my dashboard. That's why I created a new pivottable.

It might be my lack of understanding how this connection/pivot tables work. As I do not have a clue, why it is not showing up in the connection screens.
Dear Wilco,

At first delete all slicer, and pivot table. after that, create first pivot table and the copy the same pivot table and paste it down.

Now, Insert Slicer --> Right click on Slicer and make connection.

You will have all of your pivot tables in slicer.

Hope it will work.

CMA Vishal Srivastava
 

Wilco()

Member
Thanks Vishal, Just copying the pivot table was sufficient. The links were created automatically.
 

Wilco()

Member
BTW, is this the way to work in Excel? Or is there an explanation why creating a new table using the exact same data is not working?
 

ashish mehra

Active Member
Hi Wilco,

I am maintaining & successfully running Slicer Dashboard for last 5 months.
As per my knowledge try creating Pivot from Power Pivot & then add Slicers. This will enable the connection issue.

Hope this will be resolve your problem!

Let me know if you need further assistance.

Regards,
AM:)
 
BTW, is this the way to work in Excel? Or is there an explanation why creating a new table using the exact same data is not working?
Dear Wilco,

Each slicer is associated with specific pivot table field and if you wish to create slicer which can connect other Pivot tables, then you have to create stand-alone slicer that can be referenced by Online Analytical Processing (OLAP) cube functions or use that method which I have explained earlier.

Thanks & Regards,
CMA Vishal Srivastava
 

NumberPuncher

New Member
BTW, is this the way to work in Excel? Or is there an explanation why creating a new table using the exact same data is not working?
For users in the future having this issue, I would confirm the exact same data is being used by each pivot table you want to link.

I resolved the same problem by verifying the datasource - one of the pivot tables was including a blank column with header, the rest weren't. Once I synced them up, all became available under reported connections.
 

Anirudh0073

New Member
I just faced what wilco was having trouble with and tried whatever was mentioned to no avail. But I would like to add that I have added multiple pivot tables on separate sheets and the created pivotcharts and moved them to a dashboard sheet. In the process only a few tables are showing up in the report connections section of slicers. Any help would be appreciated.
 

Attachments

I also struggled with the problem of not seeing the pivot tables when i right click slicer < report connections . I used Vishal's solution of copying and pasting the original pivot to make copies. I also make it a good practice to custom name all my pivot tables and slicers to make tracking easier. Looks like what works in excel 2010 does not work exactly in the same way in Excel 2013.
 
I also struggled with the problem of not seeing the pivot tables when i right click slicer < report connections . I used Vishal's solution of copying and pasting the original pivot to make copies. I also make it a good practice to custom name all my pivot tables and slicers to make tracking easier. Looks like what works in excel 2010 does not work exactly in the same way in Excel 2013.
Hi Jonathan,
I am also using Excel 2013 and It works perfectly. I think you should check your connections and try the method specified earlier.

CMA Vishal Srivastava
 

Paul Cooper

New Member
I had this problem, I changed my source data to a 'Named Range', then re-set the each source data for all my pivot tables, they then all appeared in Slicer Connections list.
 

wecconley

New Member
Ok so I had the same problem, working on some trial/error.
First off when you create your slicer it can't be the same field as the pivot tables current field that you're creating the slicer from (eg. pivottable1 uses "User" field then the slicer stemming from pivottable1 can't be sliced by "User" other wise you can't make the connection to another pivottable)
 

wecconley

New Member
Ok so I had the same problem, working on some trial/error.
First off when you create your slicer it can't be the same field as the pivot tables current field that you're creating the slicer from (eg. pivottable1 uses "User" field then the slicer stemming from pivottable1 can't be sliced by "User" other wise you can't make the connection to another pivottable)

However this can be remedied by switching the field of the pivottable you used to create the slicer to a different field making the connection then switching back. After the first time you solve this problem it shouldn't happen again. That's been my experience so far.
 
Top