1. Welcome to Chandoo.org Forums. Short message for you

    Hi Guest,

    Thanks for joining Chandoo.org forums. We are here to make you awesome in Excel. Before you post your first question, please read this short introduction guide. When posting or responding to questions please remember our values at Chandoo.org are: Humility, Passion, Fun, Awesomeness, Simplicity, Sharing Remember that we have people here for whom English is not there first language and we need to allow for this in our dealings.

    Yours,
    Chandoo
  2. Hi All

    Please note that at the Chandoo.org Forums there is Zero Tolerance to Spam

    Post Spam and you Will Be Deleted as a User

    Hui...

  3. When starting a new post, to receive a quicker and more targeted answer, Please include a sample file in the initial post.

Last Cell (Ctrl+End) is past millionth row but no data that I can find

Discussion in 'Ask an Excel Question' started by Yvonne Love, Jan 11, 2018.

  1. Yvonne Love

    Yvonne Love Member

    Messages:
    52
    I'm not ever sure how to phrase this to google it, so I thought I'd post the question here.

    I have a spreadsheet with not a lot of data per sheet that is over 66MB. I discovered that 12 of the tabs have the end cell as Q1048572 (or close). The last row with any kind of data is at the most row 300 on any of those tabs, so I tried to first clear (select cells and hit the delete key), and then actually delete (using delete row), all the blank rows after the last row with data. That didn't work - it still shows the last cell past the millionth row. Any thoughts on how to delete whatever data is making that be the last cell? I made a copy of that spreadsheet and pasted values and fixed those 12 tabs, and the size is 657kb. The "live" file has all of the formulas and such that I want so I don't want to have to recreate those if I don't have to.

    Thanks!
    YL
  2. Khalid NGO

    Khalid NGO Excel Ninja

    Messages:
    1,867
    Thomas Kuriakose likes this.
  3. Yvonne Love

    Yvonne Love Member

    Messages:
    52
    Thanks so much! One site said it could have to do with formatting, and when I selected the rows/cells below the last row and cleared formats/conditional formatting, that worked.

    Thank you!

Share This Page