• Hi All

    Please note that at the Chandoo.org Forums there is Zero Tolerance to Spam

    Post Spam and you Will Be Deleted as a User

    Hui...

  • When starting a new post, to receive a quicker and more targeted answer, Please include a sample file in the initial post.

Excel freezes until you maximize another open file

Lynn

New Member
This is an issue I've been having ever since using Excel 2013. I was hoping that it would be fixed in Windows 10, but it hasn't.
I frequently work with multiple files open, most of them minimized. (All of my files are fairly large, complex files with multiple worksheets in them.) When posting figures into one spreadsheet and moving around it using the arrow keys, it will often freeze up. Nothing I enter shows up, and the arrows don't work to move the cursor around. I stumbled on a solution: if I hit "Enter", one of the minimized files will pop up, and I just have to minimize it again to free up the file I'm working in.
When I have a ton of work to do, however, it gets really annoying to have to keep minimizing that other file! And since I'm going back and forth between these files all the time I don't want to close the minimized file(s).
I haven't been able to figure out any pattern that makes the Excel file freeze up. There's no predicting when it will happen, but it will be working fine for a while and then start that freezing up all the time. Frequent saving doesn't seem to make a bit of difference. When I mentioned this to someone at Microsoft while seeking an answer to another question, he was intrigued and said he'd never heard of this happening.
Is it happening to anybody else? Is there any way to stop it? I'm not posting sample files, because this isn't something that shows up on the file itself; it's something the software is doing. I'm really hoping that somebody else has seen this and knows how to stop it!
 

Hui

Excel Ninja
Staff member
Have you tried using a PC with more memory?

I'd suggest trying what your doing on a PC with either 8, 16 or more GB RAM

Also turn on the use of Multiple Threads
Goto File, Options, Advanced
Scroll down to: Formulas
Enable Multi-Threaded calculation
Select Use all processors
upload_2015-8-29_15-9-29.png
 

Lynn

New Member
Thanks, Hui! Multiple Threads was already turned on. I'd wondered if it was a RAM problem. For some reason, every time I buy a computer they never believe me when I tell them that I'm an extreme power user and need as much RAM as possible, so I always end up with less than I need. It always sounds like plenty when they reassure me that whatever the latest number is will be enough, but as systems get more complicated it gets eaten up quickly and becomes insufficient. I remember when 16 Mb of RAM was an ultra-modern machine!
 

fred83

New Member
Hi Hui,

I have the same issue as reported by Lynn above. Working on a computer with 16 GB RAM. Multiple Threads is on. Working in Windows 10 Pro with current Office 365.
 
Top