1. Welcome to Chandoo.org Forums. Short message for you

    Hi Guest,

    Thanks for joining Chandoo.org forums. We are here to make you awesome in Excel. Before you post your first question, please read this short introduction guide. When posting or responding to questions please remember our values at Chandoo.org are: Humility, Passion, Fun, Awesomeness, Simplicity, Sharing Remember that we have people here for whom English is not there first language and we need to allow for this in our dealings.

  2. Hi All

    Please note that at the Chandoo.org Forums there is Zero Tolerance to Spam

    Post Spam and you Will Be Deleted as a User


  3. When starting a new post, to receive a quicker and more targeted answer, Please include a sample file in the initial post.

Do not show "Open as read only" message

Discussion in 'VBA Macros' started by rolo, May 19, 2017.

  1. rolo

    rolo New Member

    Is there any workbook open event so when the user opens the file,
    it does not appear the "Open as read only" message?

    Notice that the file is not opened by vba, the file is opened manually by the user

    ThrottleWorks likes this.
  2. PCosta87

    PCosta87 Well-Known Member


    Untested but try the following:
    Code (vb):
    Private Sub Workbook_Open()

        Application.DisplayAlerts = False

    End Sub
    If it works don't forget to re-enable them at some point :)
  3. rolo

    rolo New Member

    It doesn´t work

    Seems that the only way to avoid read only message is to open the workbook from another workbook using this

    Code (vb):
    WorkBooks.Open FileName:="C:\Book1.xls", IgnoreReadOnlyRecommended:=True
    ThrottleWorks likes this.

Share This Page